Dedehtml.com

DedeCMS Error: (PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P (recommended: 'CGP') in php.ini

摘要:织梦在PHP5.3环境下报错解决方法

DedeCMS Error: (PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P (recommended: 'CGP') in php.ini

如果你的织梦程序使用在PHP5.3,会报上面的错误,这是由于PHP5.3新增了一个叫request_order配置选项,request_order默认值为GP

也就是说默认配置下$_REQUEST只包含$_GET和$_POST而不包括$_COOKIE,通过 COOKIE就可以提交GLOBALS变量,从而绕过了大多开源程序中的全局变量防御

因此要将次选项更改为 request_order = "CGP"

2种解决方法 推荐第一种

第一种(推荐):不使用PHP5.3,用其他PHP版本

第二种(不推荐):把request_order改成CGP

版权声明:本文为博主原创文章,未经博主允许不得转载。https://www.dedehtml.com/notes/dede-request-order.html
(7)
打赏 微信扫一扫 微信 支付宝 QQ 扫码打赏